Issues with outgoing email
Incident Report for Teem
Resolved
The issue with outgoing email has been resolved. All systems are operational.
Posted 5 months ago. Jun 26, 2018 - 14:57 MDT
Identified
Outgoing email has been temporarily disabled, we have identified the problem and hope to have a resolution soon.
Posted 5 months ago. Jun 26, 2018 - 08:54 MDT
This incident affected: Mandrill US East and Mandrill US West.