Google Sync Latency
Incident Report for Teem
Resolved
The Google Calendar Sync issue has been resolved and all systems are now operational. Thank you for your patience.
Posted 7 months ago. Jan 25, 2018 - 17:02 MST
Identified
Teem has identified and is working to resolve an issue with Google sync latency. We will post updates as they are available.
Posted 7 months ago. Jan 25, 2018 - 14:08 MST