app.teem.com is down
Incident Report for Teem
Resolved
Database replication issues caused the site to become unresponsive. All systems should be back online and operational.
Posted 8 months ago. Apr 04, 2018 - 16:40 MDT
Investigating
We have identified an issue with our dashboard and back end tools. We will continue to post updates via this channel
Posted 8 months ago. Apr 04, 2018 - 16:22 MDT