Office 365 Calendar Synchronization Delay
Incident Report for Teem
Resolved
All backlogged sync jobs have completed and the system is operating as normal.
Posted 2 months ago. Jun 13, 2018 - 16:01 MDT
Monitoring
Teem has identified and is monitoring a calendar synchronization delay for Office 365 calendar users. This may cause delays in EventBoard meeting updates. Any backlogged updates will be cleared shortly.
Posted 2 months ago. Jun 13, 2018 - 14:09 MDT
This incident affected: Exchange Sync.