app.teem.com unreachable
Incident Report for Teem
Resolved
App.teem.com is back to full function.
Posted 2 months ago. Feb 05, 2018 - 18:43 MST
Investigating
Teem is investigating an issue preventing customers from reaching app.teem.com. We will update this page as we have more information
Posted 2 months ago. Feb 05, 2018 - 18:16 MST