O365/Exchange Calendar Sync Disruption
Incident Report for Teem
Resolved
The issue has been resolved, the backlog of requests has finished processing and the system has returned to normal processing.
Posted about 1 month ago. May 18, 2018 - 13:34 MDT
Monitoring
Teem has identified and corrected an issue preventing calendar sync for all Exchange/O365 customers. Any backlogged calendar sync requests will process over the next few hours. We will continue to monitor the situation and update accordingly.
Posted about 1 month ago. May 18, 2018 - 11:55 MDT
This incident affected: Exchange Sync.