S2 - O365 calendar Errors - 401/The parameter count cannot be less than zero errors
Incident Report for Teem
Resolved
After monitoring, our support team has received confirmation from multiple customers, after verifying their Source Systems are no longer locked, forcing a re-sync on the calendars are working as designed with out error. If you have additional questions, please reach out to our support team @ support-teem@eptura.com. A detailed RCA will be followed within 10 business days. We appreciate your patience during this service disruption.
Posted Mar 08, 2023 - 17:33 MST
Update
In efforts to resolve this issue, our team found the root cause to be related to a hotfix that was released on the evening of Monday, March 6, 2023. The hot fix was released to resolve an auto refresh issue that involved calendar credentials, thus causing 401 unauthorized errors. An internal decision was made to roll back the hot fix as there were continual retries and caused source systems (O365) to lock accounts. Some accounts are being unlocked based on source system timing and others may need to be unlocked manually.

We are continuing to monitor this issue. Please let our support team know if you continue to experience these errors after you have unlocked your source system accounts.
Posted Mar 08, 2023 - 13:20 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2023 - 10:58 MST
Identified
Our engineering team has identified the issue and will be implementing a fix shortly. We appreciate your patience through this disruption.
Posted Mar 08, 2023 - 10:16 MST
Investigating
We are currently investigating an issue with O365 Calendar Errors - Customers are receiving emails about their calendar sync being disabled. While on the Teem platform errors also appear on the resource calendar such as "The parameter count cannot be less than zero errors" or "Too many authorization attempts" and "401 Unauthorized".
Posted Mar 08, 2023 - 09:39 MST
This incident affected: Exchange Sync.