S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar
Incident Report for Teem
Postmortem

Teem Detailed Root Cause Analysis – Severity 2 – June 5, 2023 

Outlook and Google Events are not Syncing from Teem to Source Calendar 

 

Description: 

On June 5, 2023, at approximately 11:43am MST, customers support received additional reports of “Outlook and Google Calendar Events are not Syncing from Teem to Source Calendar”. An event created in Teem should sync back to the source calendar and vice versa. 

 

Type of Event: 

Performance Degradation 

 

Services\Modules Impacted: 

Production (Reservation Module)  

 

Timeline:  

On June 5, 2023, at approximately 11:43am MST, customer support received additional reports of “Outlook and Google Calendar events are not Syncing from Teem to Source Calendar”. The initial ticket was escalated to a S2 incident at 11:43am MST and posted to our status page alerting customers. Internal teams continue to investigate this issue through June 6, 2023. Our internal team identified the root cause of the issue at 9:10am MST and began work on the resolution. The status page was updated from investing to an identified phase. At 3:30pm MST a hotfix was implemented, and the status page was moved to a monitoring phase. At 4:27pm MST after the hotfix was implemented, internal teams acknowledged that calendar events are slowly being processed through the queue. The internal teams continue to monitor the queue through June 7, 2023. At 6:56am MST, all prior events created before the hotfix was implemented have been cleared. Internal teams continue to monitor new events that were created after the hotfix was released. As monitoring continued, customers reported that all calendar events are syncing at about 4:02pm MST. At 5:15pm MST, the incident was marked as resolved.  

 

Total Duration of Event: 

2 days 5 hours 32 mins 

 

Root Cause Analysis: 

Engineering teams found this was related to a release pushed out May 19, 2023.  

 

Preventative Action:  

While the engineering team fixed the regression bug. They found that there was an internal process during the release roll out that needed improvement with QA.

Posted Jun 15, 2023 - 10:52 MDT

Resolved
This incident was resolved, Wednesday June 7, 2023 (17:15 MDT). The RCA will follow shortly.
Posted Jun 07, 2023 - 17:15 MDT
Update
As we have not seen further service disruptions after the fix was implemented, we have moved to the Resolved Phase.
A Detailed RCA will be posted in this incident in 10 business days. Please stay subscribed to the page to receive updates automatically.
Posted Jun 07, 2023 - 17:14 MDT
Update
As we continue to monitor the calendar events queue, we are seeing newer events processing in a timely manner. If you are seeing a small delay in new events syncing to source calendar, using the "Calendar Refresh" functionality in Teem will assist for quicker processing of newer calendar events.
Posted Jun 07, 2023 - 13:24 MDT
Update
Calendar events that were created before the fix was implemented have been successfully processed. As new calendar events are being created, our engineering and dev ops team continue to monitor the calendar events updated queue.
Posted Jun 07, 2023 - 10:47 MDT
Update
Since the fix was implemented your external calendar events have been synced, we continue to monitor the calendar events update queue internally. You may experience a delay receiving new calendar events as the queue continues to process.
Posted Jun 07, 2023 - 07:41 MDT
Monitoring
A fix has been implemented. We are moving into the Monitoring Phase. If you reported a support ticket, our team will be reaching out shortly to confirm the resolution. Thank you for working with us during this disruption.
Posted Jun 06, 2023 - 15:30 MDT
Update
We continue to work toward a resolution for the issue, S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar.
Posted Jun 06, 2023 - 13:58 MDT
Update
We continue to work toward a resolution for the issue, S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar.
Posted Jun 06, 2023 - 11:19 MDT
Identified
The issue with S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar has been identified. The team is working on a fix and we will continue to keep you posted on the progress. Thank you and we appreciate your continued patience.
Posted Jun 06, 2023 - 09:10 MDT
Update
The team continues to work through this complex issue involving S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar. We are still in an investigating phase and will continue to provide updates throughout the day.
Posted Jun 06, 2023 - 07:41 MDT
Update
We are continuing to investigate this issue.
Posted Jun 06, 2023 - 05:37 MDT
Update
The team continues to investigate this issue. We appreciate your patience as we work through this.
Posted Jun 05, 2023 - 17:22 MDT
Update
Our team continues to investigate "S2 - Outlook and Google Calendars - Events are not Syncing from Teem to Source Calendar". We appreciate your patience as we analyze this.
Posted Jun 05, 2023 - 14:17 MDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2023 - 11:43 MDT
This incident affected: Google Apps Calendar and Exchange Sync.