We have found this issue to be mitigated and is only affecting a small subset of customers that we are working diligently to support and find a resolution. If you are experiencing issues, please don't hesitate to reach out to support.
Posted Aug 23, 2024 - 04:11 MDT
Update
We are continuing to investigate this issue. We'll be updating the status page at 4:51 AM MST
Posted Aug 23, 2024 - 00:51 MDT
Update
We are continuing to investigate this issue. We'll be updating the status page at 12:51 AM MST
Posted Aug 22, 2024 - 20:42 MDT
Update
We are continuing to investigate this issue. We'll be updating the status page at 8:51 PM MST
Posted Aug 22, 2024 - 16:49 MDT
Update
We are continuing to investigate this issue. We'll be updating the status page at 4:51 PM MST
Posted Aug 22, 2024 - 13:49 MDT
Investigating
We are currently experiencing issues with Calendar syncing. Our engineering team has been notified and we'll be updating this status page at 1:51 MST.
Posted Aug 22, 2024 - 11:51 MDT
This incident affected: Google Apps Calendar and Exchange Sync.