Teem Dashboard access issues when authenticating via SAML SSO
Incident Report for Teem
Postmortem

On the evening of Thursday, 7th of November, Teem conducted a routine code release. In this release, one of our dependent packages was updated as we continue to move to Python 3 compatibility. In addition to the package update, SAML application code was updated to appropriately use the upgraded packages. Early in the morning of 8th of November, a separate issue was found with the release put out hours before. In accordance with our process the release was reverted to last known good state. This caused the SAML specific sections of the application to no longer be compatible with the underlying dependent packages. Throughout the 8th of November the code release was altered to remove the issue noted above, and in the afternoon of the 8th was redeployed, placing the SAML application code changes back in place.

Posted Nov 11, 2019 - 12:45 MST

Resolved
The SAML SSO authentication issue has been resolved.
We apologize for the inconvenience this caused.
Posted Nov 08, 2019 - 16:05 MST
Identified
We have identified an issue with authentication to Teem systems. Customers attempting to login through SAML SSO are receiving a 500 error.

Customers using basic authentication (username/password), Google login, or Office365 login are not affected by this issue.

We are working to resolve this problem and we hope to have a fix out later today.

Next Update: 5PM MT/7PM ET
Posted Nov 08, 2019 - 14:03 MST
This incident affected: Web Interface.