Outlook - Add-in error when signing in
Incident Report for Teem
Resolved
The issue has been resolved. Microsoft recently rotated their public certificate for their Office365 token authentication. The Teem cache of this key was not updated correctly at rotation which in turn caused login attempts from add-in users in O365 configurations to fail.

The problematic cache was cleared earlier today and any affected O365+Outlook add-in clients should now be able to access the platform successfully.

Additional updates to insure that certificate rotations pose no further problems is underway and will be released in the coming weeks.
Posted Dec 05, 2019 - 12:22 MST
Monitoring
A potential fix has been implemented and Teem is currently monitoring the results
Posted Dec 05, 2019 - 10:10 MST
Update
Teem is continuing to research the issue and is pursuing multiple lines of investigation.

Additional updates to follow as progress is made.
Posted Dec 05, 2019 - 08:37 MST
Investigating
Teem has received reports that some Outlook users are receiving an error when logging in via the add-in (both native and web) reading:
"Unfortunately, we were unable to associate your external account with Teem. Contact your administrator for help. Invalid Token"

Teem is currently investigating the problem and will provide updates when available.
Posted Dec 04, 2019 - 14:55 MST
This incident affected: Mobile Data.