User Sync (Google, O365)
Incident Report for Teem
Postmortem

The issue was caused by a memory limit that stopped our user sync jobs from creating additional cache objects in our system. This was difficult to pinpoint, as the reported errors in user sync were inconsistent and difficult to reproduce. Once we were able to reproduce and determine the root cause, we increased the limit of our cache which allowed the jobs to operate normally. We have added monitoring and alerting, which should prevent this issue from occurring in the future.

Posted 26 days ago. Sep 26, 2019 - 13:54 MDT

Resolved
Not all users were being synchronized to the Teem platform from external directories.
Posted 26 days ago. Sep 26, 2019 - 13:51 MDT