Phone System Outage
Incident Report for
Teem
Resolved
This issue has been resolved. The phone systems are up again and fully functional.
We apologize for the inconvenience.
Posted
Oct
28
,
2019
-
15:04
MDT
Identified
Teem's phone system is currently down. This is affecting both inbound and outbound calls.
We are working with our provider.
If you need to contact Support, please e-mail
support@teem.com
, or open a chat.
Next Update: 7PM MT/9PM ET
Posted
Oct
28
,
2019
-
14:40
MDT
This incident affected: Phone System.
×
Subscribe to Incident
Subscribe to updates for
Phone System Outage
via . You'll receive .