Google Authentication Issues
Incident Report for Teem
Resolved
This incident has been resolved. The app has been verified by Google, and the "This app isn't verified" page no longer appears.

It is important to note this issue was unrelated to the Google Calendar events syncing issue from earlier this evening.
Posted Nov 08, 2019 - 00:55 MST
Monitoring
We are continuing to work with Google to have the "This app isn't verified" screen removed.

Users can continue using the workaround by clicking the "advanced" link at the bottom of the error screen page.

Next Update will be tomorrow, November 8 by 3pm MT/5PM ET.
Posted Nov 07, 2019 - 11:50 MST
Investigating
There is a google oauth problem that is causing users to see "This app isn't verified" when trying to add a google account for calendar or user sync, or when signing in via Google SSO.

There is a workaround: Users can move forward on the error screen by clicking the "advanced" link at the bottom of the page.

We are actively working with Google on addressing this issue.

Next update: 1PM MT/3PM ET
Posted Nov 07, 2019 - 09:22 MST
This incident affected: Google Apps Calendar.