S2 - We are investigating intermittent syncing issues with Outlook / Google Calendars
Incident Report for Teem
Postmortem

Teem Detailed Root Cause Analysis – Severity 2 – 08/29/2023

 

Description:

On August 29, 2023, at approximately 4:45am EDT, customer support started to receive reports of Calendar Events not syncing at all. When customers are booking events, Teem and Source Calendars are not syncing causing disruption in customer workflow.

 

Type of Event:

Service Disruption

 

Services\Modules Impacted:

Production – Calendars

 

Timeline:

On August 29, 2023, at approximately 4:45am EDT, customer support began to receive reports of Calendar Events not syncing at all. When customers are booking events, Teem and Source Calendars are not syncing causing disruption in customer workflow. At approximately 10:26am EDT, the engineering team identifies the issue and begins to implement the fix. At 10:36am EDT all customers are made aware that the fix has deployed to production and that we are moving into a monitoring phase. Customers begin to confirm the fix and at 11:01 EDT, the status page is marked as resolved.

Total Duration of Event:

6hrs 16mins

Root Cause:

The team continues to narrow down the root cause. However, the DevOps team identifies an internal configuration issue and begins to apply a manual fix.

 

Preventative Action:

Our internal teams are working on enhancing the observability to bring awareness to the appropriate teams.

Posted Sep 12, 2023 - 12:06 MDT

Resolved
This incident has been resolved.
Posted Aug 29, 2023 - 09:01 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2023 - 08:36 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 29, 2023 - 08:26 MDT
Update
We are continuing to investigate this issue.
Posted Aug 29, 2023 - 05:55 MDT
Investigating
We are currently investigating an issue with Teem. We will update you when we have more information.
Posted Aug 29, 2023 - 02:45 MDT
This incident affected: Google Apps Calendar and Exchange Sync.