We are investigating an issue with Teem

Incident Report for Teem

Resolved

This incident has been resolved.
Posted Apr 17, 2024 - 20:57 MDT

Investigating

We are currently investigating an issue with Teem. We will update you when we have more information.
Posted Apr 17, 2024 - 18:24 MDT